Introduction
The Wu Xing, or the Five Movements, Five Phases or Five Steps/Stages, are chiefly an ancient mnemonic device, in many traditional Chinese fields.
The doctrine of five phases describes two cycles, a generating or creation cycle, also known as "mother-son", and an overcoming or destruction cycle, also known as "grandfather-nephew", of interactions between the phases.
Generating:
- Wood feeds Fire;
- Fire creates Earth (ash);
- Earth bears Metal;
- Metal carries Water (as in a bucket or tap, or water condenses on metal);
- Water nourishes Wood.
Overcoming:
- Wood parts Earth (such as roots) (or Trees can prevent soil erosion );
- Earth absorbs (or muddies) Water (or Earth dam control the water);
- Water quenches Fire;
- Fire melts Metal;
- Metal chops Wood.
With the two types of interactions in the above graph, any two nodes are connected by an edge.
Problem
In a graph with N nodes, to ensure that any two nodes are connected by at least one edge, how many types of interactions are required at least? Here a type of interaction should have the following properties:
- It can be represented as a set of directed edges in the graph.
- For each type of interaction, there should be one and only one edge starting at each node.
- For each type of interaction, there should be one and only one edge ending at each node.
- The interactions are made up of cycles, i.e. starting from an arbitrary node and following the edges with the same type of interaction, you can always reach the starting node after several steps.
Input
For each test case, there's a line with an integer N (3 <= N < 1,000,000), the number of nodes in the graph.
N = 0 indicates the end of input.Output
For each test case, output a line with the number of interactions that are required at least.
Sample Input
5 0
Sample Output
2
Reference
http://en.wikipedia.org/wiki/Wu_Xing
题目分析:任意两个点都有联系,必须需要n*(n-1)/2条边,,要构成一个环, n个点必须要n条边,终所有环所构成的边,都不会超过n*(n-1)/2条边。 所以至少有(n-1)/2个环, 如果可以整除,那么商就是答案。如果不能整除呢? 那么余下的边必定可以再组成一个环。所以如果(n-1)%2 != 0, 那么答案就等于(n-1)/2 +1;结果就是和n/2。
#include<cstdio>
#include<math.h>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define ll long long
#define abs(x) (x>0?x:-x)
const int INF=0x7ffffff;
int main(){
int n;
while(~scanf("%d",&n),n){
printf("%d\n",n/2);
}
return 0;
}