ZOJ 3328 Wu Xing

Wu Xing

Time Limit: 1 Second      Memory Limit: 32768 KB

Introduction

The Wu Xing, or the Five Movements, Five Phases or Five Steps/Stages, are chiefly an ancient mnemonic device, in many traditional Chinese fields.

The doctrine of five phases describes two cycles, a generating or creation cycle, also known as "mother-son", and an overcoming or destruction cycle, also known as "grandfather-nephew", of interactions between the phases.

Generating:

  • Wood feeds Fire;
  • Fire creates Earth (ash);
  • Earth bears Metal;
  • Metal carries Water (as in a bucket or tap, or water condenses on metal);
  • Water nourishes Wood.

Overcoming:

  • Wood parts Earth (such as roots) (or Trees can prevent soil erosion );
  • Earth absorbs (or muddies) Water (or Earth dam control the water);
  • Water quenches Fire;
  • Fire melts Metal;
  • Metal chops Wood.

Wu Xing

With the two types of interactions in the above graph, any two nodes are connected by an edge.

Problem

In a graph with N nodes, to ensure that any two nodes are connected by at least one edge, how many types of interactions are required at least? Here a type of interaction should have the following properties:

  • It can be represented as a set of directed edges in the graph.
  • For each type of interaction, there should be one and only one edge starting at each node.
  • For each type of interaction, there should be one and only one edge ending at each node.
  • The interactions are made up of cycles, i.e. starting from an arbitrary node and following the edges with the same type of interaction, you can always reach the starting node after several steps.

Input

For each test case, there's a line with an integer N (3 <= N < 1,000,000), the number of nodes in the graph.

N = 0 indicates the end of input.

Output

For each test case, output a line with the number of interactions that are required at least.

Sample Input

5
0

Sample Output

2

Reference

http://en.wikipedia.org/wiki/Wu_Xing


题目大意:

1.这是一个有向边集;

2.只有一个起始边;

3.只有一个终点边;

4.可以组成一个环。

注意:这儿有个“坑”(只是本人被坑了),这个环是将所有点连接起来的,因为每个环要贯穿所有点,而不仅仅是最后所有环两点连通,未懂题意得情况下走的队友思路,呜呼了……

思路:所有点直接连通,需要  n*(n-1)/2条边,每个环需要n个边(多个环可能共用一条边),所以环的个数至少为  (n-1)/2,如果n-1是偶数,直接得出答案;如果n-1是奇数,剩下的边肯定又可以构成一个环,是  (n-1)/2+1(此处不好理解)。那么程序中就可写为    n/2。

代码:

#include<iostream>
using namespace std;
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        printf("%d\n",n/2);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值