HDU 4165 Pills【卡特兰数】

Pills

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 17   Accepted Submission(s) : 10
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Aunt Lizzie takes half a pill of a certain medicine every day. She starts with a bottle that contains N pills.

On the first day, she removes a random pill, breaks it in two halves, takes one half and puts the other half back into the bottle.

On subsequent days, she removes a random piece (which can be either a whole pill or half a pill) from the bottle. If it is half a pill, she takes it. If it is a whole pill, she takes one half and puts the other half back into the bottle.

In how many ways can she empty the bottle? We represent the sequence of pills removed from the bottle in the course of 2N days as a string, where the i-th character is W if a whole pill was chosen on the i-th day, and H if a half pill was chosen (0 <= i < 2N). How many different valid strings are there that empty the bottle?

Input

The input will contain data for at most 1000 problem instances. For each problem instance there will be one line of input: a positive integer N <= 30, the number of pills initially in the bottle. End of input will be indicated by 0.

Output

For each problem instance, the output will be a single number, displayed at the beginning of a new line. It will be the number of different ways the bottle can be emptied.

Sample Input

6
1
4
2
3
30
0

Sample Output

132
1
14
2
5
3814986502092304
    题意:一个瓶子里有n片药,每次吃半片,从瓶子里可能取出整片,也可能取出半片,如果取到的药是整片的,就把它分成两半,吃掉其中的一半,另一半重新放入瓶中,如果取到半粒药,则直接吃掉。问2n天内吃完药有多少种取法。
 
   分析:第一次一定取出的是整片,最后一次取出来的一定是半片,只有先取出整片,才有取出半片的可能。n片药,一定是2n次取完的,这2n次一定是取n次整片,n次半片,且取出整片的次数一定一直大于等于取出半片的次数,即卡特兰数。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
#define ll long long
#define ms(a,b)  memset(a,b,sizeof(a))
const int M=1e3+10;
const int inf=0x3f3f3f3f;
const int mod=1e9+7;
int i,j,k,n,m;
ll dp[M][M];

int main()
{
    for(int i=0;i<33;i++)dp[0][i]=1;
    for(int i=1;i<33;i++)
        for(int j=i;j<33;j++)
            dp[i][j]=dp[i-1][j]+dp[i][j-1];
    while(~scanf("%d",&n),n){
        printf("%lld\n",dp[n][n]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值