pills

2087 - Pills

Aunt Lizzie takes half a pill of a certain medicine every day. She starts with a bottle that contains N pills.

 

On the first day, she removes a random pill, breaks it in two halves, takes one half and puts the other half back into the bottle.

On subsequent days, she removes a random piece (which can be either a whole pill or half a pill) from the bottle. If it is half a pill, she takes it. If it is a whole pill, she takes one half and puts the other half back into the bottle.

In how many ways can she empty the bottle? We represent the sequence of pills removed from the bottle in the course of 2N days as a string, where the i-th character is W if a whole pill was chosen on the i-th day, and H if a half pill was chosen (0 <= i < 2N). How many different valid strings are there that empty the bottle?

 

Input

The input will contain data for at most 1000 problem instances. For each problem instance there will be one line of input: a positive integer N <= 30, the number of pills initially in the bottle. End of input will be indicated by 0.

Output

For each problem instance, the output will be a single number, displayed at the beginning of a new line. It will be the number of different ways the bottle can be emptied.

Sample Input

6
1
4
2
3
30
0

Sample Output

132
1
14
2
5
3814986502092304

Source

Rocky Mountain Regional Contest (2011)




记住图片做教训,此类题目不能在不能A了

代码:

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
long long dp[40][40]={0};
int main()
{
       dp[0][1]=1;
       for(int i=1;i<=31;i++)
       {
           for(int j=1;j<=i;j++)
           {
               long long sum=0;
               for(int k=1;k<=j;k++)
               sum+=dp[i-1][k];
               dp[i][j]=sum;
           }
       }
       int num;
       while(scanf("%d",&num),num)
       {
           printf("%I64d\n",dp[num+1][num+1]);
       }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值