POJ - 3126  Prime Path【图论bfs】

Prime Path

 POJ - 3126 

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 

1033 
1733 
3733 
3739 
3779 
8779 
8179

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

思路:图论->bfs

#include<iostream>
#include<vector>
//#include"point.h"
#include<algorithm>
#include<cstring>
#include<stdio.h>
#include<queue>
using namespace std;

typedef struct {
  int digit[4];
  int steps;
}dig;

int stt,edd,ans;
int flag[11000];
int st[10],ed[10];

void init()
{
  memset(flag,0,sizeof(flag));
  for(int i=2;i*i<10000;i++)
     for(int j=2;j*i<10000;j++)
       flag[i*j]=true;

}

void tosz()
{
   int temp=stt;
   int pos=0;
   while(temp!=0){
     st[pos++]=temp%10;
     temp/=10;
   }
   pos=0;
   temp=edd;
   while(temp!=0){
     ed[pos++]=temp%10;
     temp/=10;
   }
}

int tonum(dig temp)
{
  int base=1;
  int sum=0;
  for(int i=0;i<4;i++){
    sum+=base*temp.digit[i];
    base*=10;
  }
  return sum;
}

void  bfs()
{
  queue<dig>q;
  dig temp;
  for(int i=0;i<4;i++)temp.digit[i]=st[i];
  temp.steps=0;
  q.push(temp);
  while(!q.empty()){
    dig cur=q.front();
    q.pop();
    int num=tonum(cur);
    if(num==edd){
       ans=cur.steps;
       break;
    }
    for(int i=0;i<4;i++){
      temp=cur;
      temp.steps=cur.steps+1;
      for(int j=0;j<10;j++){
        temp.digit[i]=j;
        num=tonum(temp);
        if(flag[num]==1||num<1000)continue;
        else {
          flag[num]=1;
          q.push(temp);
        }
      }
    }
   } 
   while(!q.empty())q.pop();
}
 



int main()
{
     int t;
     scanf("%d",&t);
     while(t--){
       scanf("%d%d",&stt,&edd);
       init();
       tosz();
       bfs();
       printf("%d\n",ans);
     }

     return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值