差分+树状数组F - A Simple Problem with Integers

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output
You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.

#include<iostream>
#include<cstdio>
#include<sstream>
#include<cstring>
#include<vector>
#include<queue>
#include<cmath>
#include<algorithm>
#include<map>
#include<set>
#include<fstream>
using namespace std;
const int maxn=1e5+10;
int color[35];
struct node{
	int l,r,num,lazy;
}a[maxn<<2];
int result;
void update(int k)
{
	a[k].num=a[k<<1].num|a[k<<1|1].num;
}

void build(int k,int l,int r)
{
	a[k].l=l;
	a[k].r=r;
	if(l==r)
	{
		a[k].num=1;
		return ;
	}
	int mid=(l+r)>>1;
	build(k<<1,l,mid);
	build(k<<1|1,mid+1,r);
	update(k);
}
void pushdown(int k)
{
	if(!a[k].lazy) return;
	a[k<<1].num=a[k].lazy;
	a[k<<1|1].num=a[k].lazy;
	a[k<<1].lazy=a[k<<1|1].lazy=a[k].lazy;
	a[k].lazy=0;
	update(k);
	return;
}
void change(int k,int l,int r,int t)
{
	if(a[k].l>=l&&a[k].r<=r)
	{
		a[k].lazy=t;
		a[k].num=t;
		return;
	}
	pushdown(k);
	int mid=(a[k].l+a[k].r)>>1;
	if(l<=mid) change(k<<1,l,r,t);
	if(r>mid) change(k<<1|1,l,r,t);
	update(k);
}
void solve(int k,int l,int r)
{
	if(a[k].l>=l&&a[k].r<=r)
	{
		result=result|a[k].num;
		return ;
	}
	pushdown(k);
	int mid=(a[k].l+a[k].r)>>1;
	if(l<=mid) solve(k<<1,l,r);
	if(r>mid) solve(k<<1|1,l,r);
	update(k);
}
int main()
{
	int n,T,o;
	while(scanf("%d%d%d",&n,&T,&o)!=EOF)
	{
		build(1,1,n);
		for(int i=1;i<=o;i++)
		{
			char ch;
			cin>>ch;
			switch(ch)
			{
				case 'C':
					{
						int l,r,t;
						scanf("%d%d%d",&l,&r,&t);
						if(l<r) change(1,l,r,1<<(t-1));
						else change(1,r,l,1<<(t-1));
						break;
					}
				case 'P':
				{
					int l,r;
					result=0;
					scanf("%d%d",&l,&r);
					if(l<r) solve(1,l,r);
					else solve(1,r,l);
					int sum=0;
					while(result>0)
					{
						sum++;
						result-=result&(-result);
					}
					printf("%d\n",sum);
					break;
				}
			}
		}
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值