Problem H 编写函数atof()

116 篇文章 2 订阅
45 篇文章 9 订阅

Problem Description
编写函数atof(char s[])和read_line(char str[], int n),将字符串转换为对应数值的小数。
测试程序为:
#include <stdio.h>
#include <ctype.h>

#define STR_LEN 20

int read_line(char str[], int n); //n为字符串的长度,返回实际读入的字符个数
double atof(char s[]);

int main()
{
    char str[STR_LEN + 1];

    read_line(str, STR_LEN);
    printf("%f\n", atof(str));

    return 0;
}
/* 你的代码将被嵌在这里 */
Input Description
在一行中输入一个字符串。
Output Description
输出字符串对应数值的小数。
Sample Input
    +123.456
Sample Output
123.456000


答案:
#include <stdio.h>
#include <ctype.h>

#define STR_LEN 20

int read_line(char str[], int n); //n为字符串的长度,返回实际读入的字符个数
double atof(char s[]);

int main()
{
    char str[STR_LEN + 1];

    read_line(str, STR_LEN);
    printf("%f\n", atof(str));

    return 0;
}
int read_line(char str[], int n)
{
    gets(str);
}
 

#include <stdio.h>
#include <ctype.h>

#define STR_LEN 20

int read_line(char str[], int n); //n为字符串的长度,返回实际读入的字符个数
double atof(char s[]);

int main()
{
    char str[STR_LEN + 1];

    read_line(str, STR_LEN);
    printf("%f\n", atof(str));

    return 0;
}
int read_line(char str[], int n)
{
    gets(str);
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小木苓

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值