Problem A: 实验八:成绩异常处理

Problem Description

1.实验目的
(1) 熟悉异常的抛出与捕获的含义;
(2) 掌握异常捕获与处理的方法;
(3) 能自定义异常。

2.实验内容
  编写成绩管理应用程序,其中有成绩录入模块,成绩录入过程中,录入的成绩不在合理的范围(比如小于0或者大于100),若出现上述错误,程序抛出异常(小于0抛出异常打印negative,大于100抛出异常打印 too high)。

3.实验要求
  请将下列代码补充完整
  import java.util.*;

  public class Main{
    public static void main(String arg[])
    {
      ExceptionDemo demo = new ExceptionDemo();
     demo.inputScore();
    }
  }
  // 你的代码
 

 

 Input Description

 

 

 Output Description

 

Sample Input

59,45,78,-10,39,62,130

 Sample Output

negative
too high

 Hint

 我的想法:

 我的代码:

package com.zuoye.Main;

import java.util.Scanner;

public class Main {

    public static void main(String arg[]) {
        ExceptionDemo demo = new ExceptionDemo();
        demo.inputScore();
    }
}

// 你的代码
class ExceptionDemo {
    public ExceptionDemo() {

    }

    public void inputScore() {
        Scanner scanner = new Scanner(System.in);
        /*读取成绩*/
        String[] split = scanner.nextLine().split(",");
        for (String s : split) {
            int grade = Integer.parseInt(s);
            if (grade < 0) {
                try {
                    throw new ExceptionCode("negative");
                } catch (ExceptionCode e) {
                    System.out.println(e.getMessage());
                }

            }
            if (grade > 100) {
                try {
                    throw new ExceptionCode("too high");
                } catch (ExceptionCode e) {
                    System.out.println(e.getMessage());
                }
            }
        }
    }
}

class ExceptionCode extends Exception {
    /**
     * 空参构造
     */
    public ExceptionCode() {
    }

    /**
     * @param message 表示异常提示
     */
    public ExceptionCode(String message) {
        super(message);
    }
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

会编程的七七

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值