POJ 3067 Japan【树状数组】

题目

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, … from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

题目大意

T组数据,每一组数据都是左右两边有若干个城市,现在需要在左右两边各取一座城市修建公路,城市按照序号大小顺序排列,两边的城市均在[1,1000]之间,输出最后公路的交界点数目。

input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

output

For each test case write one line on the standard output:
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

分析

由分析可以知道,当点对为(1,2),(2,3),(3,4)时,并没有产生交界点。只有(1,3),(2,1)这样的情况时产生了交界点。在这里,x的数据1,2按照升序,但是y的数据3,1则是降序,则计算交界点的数目问题变成了求取逆序对数目的问题,按照x升序的顺序去输入。城市按照x,y的点对形式给出,城市x在左,y在右,那么,我们可以先将其按照x升序排列,x相等时,再按照y升序排列。
计算y对应的前缀和获得非逆序数目,并更新该y对应的值。可采用树状数组进行处理。
树状数组

代码

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int a[1010];
int n,m;
struct E{
	int x,y;
}edge[1000010];
bool cmp(const E a,const E b){//x优先,y其次升序排列
	if(a.x<b.x) return true;
	else if(a.x==b.x) return a.y<b.y;
	return false;
}
int lowbit(int x){
	return (-x)&x;
}
void add(int i){//点更新
	while(i<=m){
		a[i]++;
		i+=lowbit(i);
	}
}
int getsum(int i){//查询前缀和
	int ans = 0;
	while(i>0){
		ans+=a[i];
		i-=lowbit(i);
	}
	return ans;
}
int main(){
	int t,k;
	scanf("%d",&t);
	for(int i= 1;i<=t;++i){
		scanf("%d %d %d",&n,&m,&k);
		for(int j= 0;j<k;++j) scanf("%d %d",&edge[j].x,&edge[j].y);
		sort(edge,edge+k,cmp);//排序
		long long ans = 0;
		for(int j = 0;j<k;++j){
			ans+=j-getsum(edge[j].y);//getsum计算出前缀和为非逆序数目
			add(edge[j].y);//按照x升序的顺序更新数据
		}
		printf("Test case %d: %lld\n",i,ans);
		memset(a,0,sizeof a);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

registor11

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值