POJ 1837——Balance【分组背包】

22 篇文章 0 订阅

题目传送门

平衡问题,把每个砝码在每个位置的权值算出来,每个砝码一个分组,几个位置几个物品,最后求的是价值和为0的方案数。


Description

Gigel has a strange “balance” and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm’s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1…25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.


Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15…15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-’ for the left arm and ‘+’ for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1…25 representing the weights’ values.


Output

The output contains the number M representing the number of possibilities to poise the balance.


Sample Input

2 4
-2 3
3 4 5 8


Sample Output

2


题意:

有C个挂钩,G个砝码,求使天平平衡的方案数。


分析:

  • 每个砝码看做一组,同一砝码在不同位置的贡献作为组内不同物品
  • 方案数问题,状态转移方程:dp[k][j +权值] += dp[k - 1][j];

AC代码:

#include <iostream>
#include <vector>
#include <utility>
#include <cstring>
#include <algorithm>
#include <map>
#include <queue>
#include <stack>
#include <cstdio>
#include <fstream>
#include <set>
using namespace std;
typedef long long ll;
#define ios ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);

#define INF 0x3f3f3f

const int MAXN = 7500 * 2 + 7;

int dp[25][MAXN];
int c[25], g[25];
vector<int>vec[MAXN];
int main() {
	ios;
	int C, G;
	int balance = 7500;
	while (cin >> C >> G) {
		memset(dp, 0, sizeof dp);
		for (int i = 0; i <= C * G; i++) {
			vec[i].clear();
		}
		dp[0][balance] = 1;
		for (int i = 1; i <= C; i++)
			cin >> c[i];
		for (int i = 1; i <= G; i++) {
			cin >> g[i];
			for (int j = 1; j <= C; j++) {
				vec[i].push_back(g[i] * c[j]);
			}
		}
		for (int k = 1; k <= G; k++) {
			for (int j = 15000; j >= 0; j--) {
				for (int i = 0; i < vec[k].size(); i++) {
					dp[k][j + vec[k][i]] += dp[k - 1][j];
				}
			}
		}
		cout << dp[G][balance] << endl;
	}
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值