PAT(甲级)1002 A+B for Polynomials(关键点)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

 

        本题考察的就是简单的编程基础,但是通过率却很低,感觉应该是有的同学没有考虑到一些细节,所以在这里啰嗦几句。

        本题大意就是简单的多项式加法,将系数加起来输出。主要有两个坑要注意:

        1、题目末尾这句保留一位小数真不是废话,题目会给多位小数的系数,所以输出时一定要注意保留一位小数。

        2、题目要求结果末尾一定不能有空格,但在本题中我们也不知道一共有多少的数据要输出,所以要注意数据结构的选取。再一个就是本题最后一个测试点的输出只有一个0,算是一个特例,这个0后面的空格也不能加。

        在本题中我选了vector+pair来保存结果,这样可以借助vector可以索引的特点来控制空格的输出。代码如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int num1,num2,n;
	float N1[1001],N2[1001],a;
	for(int i=0;i<1001;i++)
		N1[i]=N2[i]=0;
	
	vector<pair<int,float> > res;	
	cin>>num1;
	for(int i=0;i<num1;i++)
	{
		cin>>n>>a;
		N1[n]=a;
	}
	cin>>num2;
	for(int i=0;i<num2;i++)
	{
		cin>>n>>a;
		N2[n]=a;
	}
	for(int i=0;i<1001;i++)
	{
		float temp=N1[i]+N2[i];
		if(temp!=0)
			res.push_back(make_pair(i,temp));
	}
	
	cout<<res.size();
	if(res.size()!=0)
		cout<<" ";
	for(int i=res.size()-1;i>=0;i--)
	{
		cout<<res[i].first<<" ";
		printf("%.1f",res[i].second);
		if(i!=0)
			cout<<" ";
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值