HDU 1712 ACboy needs your help

分组背包
HDU 1712
Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.
Of course,the profit(利润) he will gain from different course depending on the days he spend on it.
How to arrange the M days for the N courses to maximize(取…最大值) the profit?


Input
The input consists of multiple data sets.
A data set starts with a line containing two positive(积极的) integers(整数) N and M, 
N is the number of courses, M is the days ACboy has.
Next follow a matrix(矩阵) A[i][j], (1<=i<=N<=100,1<=j<=M<=100).
A[i][j] indicates(表明) if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.


Output
For each data set, your program should output(输出) a line which contains the number of the max profit ACboy will gain.


Sample Input
2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0


Sample Output
3
4
6
题意:
一个学生用M天的时间复习N门课程,每门课程花费不同的天数,有不同的收获。问如何安排这M天,使得收获最大。
思路:
分组背包(背包九讲)

for 所有的组k
    for v=V..0
        for 所有的i属于组k
            f[v]=max{f[v],f[v-c[i]]+w[i]}

#include <stdio.h>
#include <iostream>
#include <cstring>
using namespace std;
int max(int x,int y)
{
    return x>y?x:y;
}
int main()
{
    int n,K,i,j;
    int dp[105],a[105];
    while(cin>>n>>K)
    {
        if(n+K==0)
        break;
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=K;j++)
            {
                cin>>a[j];
            }
            for(j=K;j>0;j--)
            {
                for(int k=j;k>0;k--)
                    dp[j]=max(dp[j],dp[j-k]+a[k]);
            }
        }
        cout<<dp[K]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值