出栈合法性检测

题目
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3,, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:
YES
NO
NO
YES
NO
#include <stdio.h>  
#define maxn 1005  
int stack[maxn];  
int out[maxn];  
int check(int m,int n) 
{  
//利用return快速结束判断
    int po=0,top=0;  //top元素模拟栈,po记录当前入栈元素
    for(int i=1;i<=n;i++)  
    {  //out[i]为当前需出栈元素
        for(int j=po+1;j<=out[i];j++)  
        {  
            po=j;  
            stack[top++]=j;  
			if(top>m) return 0; 	
        }  
        if(stack[--top]!=out[i])  
			return 0;  
    }  
    return 1;  
}  
int main()  
{  
    int m,n,k;  
    scanf("%d %d %d",&m,&n,&k);
	while(k--){
		for(int i=1;i<=n;i++){  
			scanf("%d",&out[i]);  
		}  
		if(check(m,n))  
			printf("YES\n");  
		else  
			printf("NO\n"); 	
	}
    return 0;  
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值