Tree Cutting

After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses. 

Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ. 

Please help Bessie determine all of the barns that would be suitable to disconnect.

Input

* Line 1: A single integer, N. The barns are numbered 1..N. 

* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.

Output

* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".

Sample Input

10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8

Sample Output

3
8

Hint

INPUT DETAILS: 

The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles. 

OUTPUT DETAILS: 

If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).

题意:

一棵树,有n个节点,删除哪些节点使其剩下的子图的节点数不超过n/2,如果结果有多个则按从小到大输出;

思路:

任选一个节点,dfs该节点,求出该节点的最大子树和子树之和temp,如果n-temp和最大子树斗不超过n/2,即为结果;

源程序:#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node//建立结构体
{
    int a,b,c;
};
struct node s[20010]={0};
int st[10010]= {0};
int fun(int u,int v)
{
    int t,temp;
    if(s[v].c!=0)
        return s[v].c;
    t=st[s[v].a];
    temp=1;
    while(t!=0)
    {
        if(s[t].a!=u)
            temp+=fun(s[v].a,t);//遍历分割后的子图节点·,求和·
        t=s[t].b;
    }
    s[v].c=temp;//记录最大子树
    return temp;
}
int main()
{
    int i,n,a1,b1,t,flag;
    scanf("%d",&n);
    for(i=1; i<=n-1; i++)
    {
        scanf("%d%d",&a1,&b1);//输入,初始化
        s[i].a=b1;
        s[i].b=st[a1];
        st[a1]=i;
        s[i+n].a=a1;
        s[i+n].b=st[b1];
        st[b1]=i+n;
    }
    for(i=1; i<=n; i++)
    {
        flag=1;
        t=st[i];
        while(t!=0)
        {
            if(fun(i,t)>(n/2))//判断分割后的子图节点是否大于n/2;
            {
                flag=0;//若节点数超过n/2,则标记为0
                break;
            }
            t=s[t].b;
        }
        if(flag)
            printf("%d\n",i);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值