-ROADS

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has. 

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 

  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100


Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

题意:有n个城市,已知某人的总钱数和n条路的距离,和车费,让你在花费不超过总钱数的条件下求最短1到n的路程,
若没有输出-1;
思路:采用dfs,建立邻接表,求出最短路程
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int k,n,r,sum,flag;
int s[10010],d[10010],l[10010],t[10010];
int first[10010],next[10010],book[10010];
void dfs(int st,int coins,int temp)
{
    if(coins>k)return;//超过总钱数
    if(temp>sum)return;//剪枝
    if(st==n&&coins<=k)//到达目的地钱数小于总钱数
    {
        if(temp<sum)//最短路
        {
            flag=1;
            sum=temp;
        }
        return;
    }
    for(int i=first[st];i!=-1;i=next[i])//搜索
    {
        if(book[d[i]]==0)
        {
            book[d[i]]=1;dfs(d[i],coins+t[i],temp+l[i]);
            book[d[i]]=0;

        }
    }
}

int main()
{
    while(~scanf("%d%d%d",&k,&n,&r))
    {
        memset(first,-1,sizeof(first));//
        memset(next,-1,sizeof(next));
        memset(book,0,sizeof(book));
        for(int i=1;i<=r;i++)
        {
            scanf("%d%d%d%d",&s[i],&d[i],&l[i],&t[i]);
            next[i]=first[s[i]];//next[i]存储"编号为i的边"的"下一条边"
            first[s[i]]=i;//first[i]保存顶点s[i]的第一条边的编号        }
        sum=0x3f3f3f3f;
        book[1]=1;
        flag=0;
        dfs(1,0,0);
        if(!flag)
        printf("-1\n");
        else
            printf("%d\n",sum);
    }
    return 0;
}
 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值