IOI 1994 The_Triangle 题解

蒟蒻的第一篇题解吧,,,也是蒟蒻的第一个AC的DP题。

感觉这个应该是当年的一道签到题了。。。

题目是这样的。。。(蒟蒻从自家学校OJ上扒的,不知道是不是,不是也凑合着当是看吧23333)

Description

 

        7
      3   8
    8   1   0
  2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

读完题就会发现这是一道标准的不能再标准的DP题了,状态转移方程是f[i][j] = max(f[i - 1][j], f[i - 1][ j - 1]) (蒟蒻不会写这东西,要是写错了dalao不要喷qwq)

然后就是套循环实现了。。。在不要求原数据的情况下可以直接用一个数组来实现,应该早就有dalao想到这个方法了。。。

不多说了,直接贴代码啦。(蒟蒻的代码还是太繁琐了)

#include <iostream>
#include <cstring>
#define max(a,b) ((a)>(b)?(a):(b))

typedef long long ll;

int main()
{
	using namespace std;
	long long n;
	
	cin >> n;
	int* ans = new int[n];
	int now = 0;
	ll index = 0;
	memset(ans, 0, sizeof(int) * n);
	for (ll i = 0; i < n; i++)
	{
		for (ll l = 0; l <= i; l++)
		{
			cin >> now;
			ans[i - l] = now + max(ans[i -l], ans[i - l - 1]);
		}
	}
	int max = 0;
	for (int i = 1; i < n; i++)
	{
		if (ans[i] > ans[max])
			max = i;
	}
	max = ans[max];
	cout << max;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值