题目叙述
Description
7 3 8 8 1 0 2 7 4 4 4 5 2 6 5 (Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
Sample Output
30
Source
代码描述
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
int n;
int a[105][105];
int A[105][105]={0};
cin>>n;
for(int i=0; i<n; i++)
{
for(int j=0; j<=i; j++)
cin>>a[i][j];
}
for(int i=0; i<n; i++)
{
A[n-1][i]=a[n-1][i];
}
for(int i=n-2; i>=0; i--)
{
for(int j=0; j<n-1; j++)
A[i][j]=(a[i][j]+max(A[i+1][j],A[i+1][j+1]));
}
cout<<A[0][0];
return 0;
}
题目解析
动态规划的简单应用:
状态转移方程为: A[i][j]=(a[i][j]+max(A[i+1][j],A[i+1][j+1]));(a[i][j]表示当前状态,A[i][j]表示指标函数)
从第n层向上判断,取最大值即可。