PAT 1096 甲级 Consecutive Factors (20分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.
Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2​31​​).
Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]factor[2]…*factor[k], where the factors are listed in increasing order, and 1 is NOT included.
Sample Input:

630

Sample Output:

3
567

这题要求一定数学功底,逻辑想不出来就别强求了…
利用两次循环。
第一次循环从i = 2 开始,一直到N的开平方为止。因为开平方之后的计算都不成立。
内部的第二次循环要求连续 j 都是N的因子,只要N%j != 0 即求下一个j++。否则退出循环,外层i++。
第二次循环期间要求计算满足条件 j 的个数。
在第一次循环结束末尾,判断MAX和满足条件的pos(PS:就是i) 是否需要更换。
输出结果。

#include<iostream>
#include<vector>
#include<algorithm>
#include<math.h>

using namespace std;

int main(){
	int N;
	cin>>N;
	int i  = 2,j = 2;
	int sqr = sqrt(1.0*N);
	int count = 0;
	int n = N;
	int max = 0;
	int start = N;
	while(j <= sqr){
		i = j ;
		while(i <= n){
			if(N%i == 0){
				N /= i;
				count++;
				i++;
			}else{
				break;
			}
		}
		if(max < count){
			max = count;
			start = j;
		}
		N = n ;
		j++;
		count = 0;
	}
	if(max){
		cout<<max<<endl;
		for(int i = 0;i < max;i++){
			if(!i){
				cout<<start;
			}else{
				cout<<"*"<<start + i;
			}			
		}
	}else{
		cout<<1<<endl;
		cout<<n;
	}
	
	
	return 0;
}

前辈传送门…

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值