PAT 1091 甲级 Acute Stroke (30分)

One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.
Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M×N matrix, and the maximum resolution is 1286 by 128); L (≤60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M×N matrix of 0’s and 1’s, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1’s to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are connected and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.

Figure 1
Output Specification:

For each case, output in a line the total volume of the stroke core.
Sample Input:

3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0

Sample Output:

26

原理是BFS或者DFS。
这里选择BFS。
给出一个三维的空间,仅有0,1。
计算成群size >= 2的标记1的总数。
初始化三维访问数组。
三层循环依次遍历每个有效点(如果访问标记为true,就跳过),每个点的坐标作为参数进行BFS。
在BFS期间,利用一个辅助队列。每个点都要实现向 6个方向搜索1步。成功,则计数加1。
单点BFS结束后,返回有效计数。累加。
结果输出。

#include<iostream>
#include<queue>

using namespace std;
int n,m,slice,T;
int pixel[1290][130][61];
bool inq[1290][130][61] = {false};
int X[6] = {0,0,0,0,1,-1};
int Y[6] = {0,0,1,-1,0,0};
int Z[6] = {1,-1,0,0,0,0};
struct node {
	int x,y,z;
}Node;

bool judge(int x,int y,int z){
	if(x >= n || x < 0 || y >= m || y < 0 || z >= slice || z < 0){
		return false;
	}
	if(pixel[x][y][z] == 0 || inq[x][y][z] == true){
		return false;
	} 
	return true;
}

int BFS(int x,int y,int z){
	int tot = 0;
	queue<node> Q;
	Node.x = x;
	Node.y = y;
	Node.z = z;
	Q.push(Node);
	inq[x][y][z] = true;
	while(!Q.empty()){
		node top = Q.front();
		Q.pop();
		tot++;
		for(int i = 0;i < 6;i++){
			int newX = top.x + X[i];
			int newY = top.y + Y[i];
			int newZ = top.z + Z[i];
			
			if(judge(newX,newY,newZ)){
				Node.x = newX;
				Node.y = newY;
				Node.z = newZ;
				Q.push(Node);
				inq[newX][newY][newZ] = true;
			}
		}
	}
	if(tot >= T){
		return tot;
	}else{
		return 0;
	}
	
}

int main() {
	cin>>n>>m>>slice>>T;

	for(int z = 0; z < slice ; z++) {
		for(int x = 0 ; x < n ; x++) {
			for(int y = 0; y < m; y++) {
				cin>>pixel[x][y][z];
			}
		}
	}
	int ans = 0;
	for(int z = 0; z < slice ; z++) {
		for(int x = 0 ; x < n ; x++) {
			for(int y = 0; y < m; y++) {
				if(pixel[x][y][z] == 1 && inq[x][y][z] == false) {
					ans += BFS(x,y,z);
				}
			}
		}
	}
	cout<<ans;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值