【PAT刷题甲级】1083.List Grades

1083 List Grades (25 分)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

Output Specification

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output NONE instead.

Sample Input 1

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2

NONE

题意

根据学生信息,输出指定成绩范围内的学生姓名和ID。

代码

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct node {
	string name,id;
	int grade;
};
bool cmp(node a,node b) {
	return a.grade > b.grade;
}
int main() {
	int n,c,gmin,gmax;
	cin >> n;
	vector<node> v(n+1);
	string a,b;
	for(int i=0; i<n; i++) {
		cin >> a >> b >> c;
		v[i].name=a;
		v[i].id=b;
		v[i].grade=c;
	}
	cin >> gmin >> gmax;
	sort(v.begin(),v.end(),cmp);
	int flag=0;
	for(int i=0; i<n; i++) {
		if(v[i].grade>=gmin && v[i].grade<=gmax) {
			flag=1;
			printf("%s %s\n",v[i].name.c_str(),v[i].id.c_str());
		}
	}
	if(flag==0)	printf("NONE");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
这段代码中可能存在以下错误: 1. 头文件`<malloc.h>`是非标准库头文件,应该使用标准库头文件`<stdlib.h>`。 2. 在动态分配内存时,应该检查是否分配成功,如果分配失败,则应该处理错误。 3. 当`m`乘以1.5时,结果可能是一个浮点数,应该将其转换为整数,例如使用`(int)(m * 1.5)`。 4. 在找到排名时,当`m`大于等于`n`时,循环会一直进行下去,导致数组越界。 5. 在找到排名时,循环条件错误,应该是`while(p[i].grades == grades && i < n)`。 下面是修改后的代码: ``` #include <stdio.h> #include <stdlib.h> typedef struct { int id, grades; } Information; int main() { int n, m, grades; scanf("%d %d", &n, &m); m = (int)(m * 1.5); Information *p = (Information *)malloc(n * sizeof(Information)); if (p == NULL) { printf("Memory allocation failed.\n"); return 1; } for (int i = 0; i < n; i++) { scanf("%d %d", &p[i].id, &p[i].grades); } Information q; for (int i = 0; i < n; i++) { for (int j = 0; j < n - 1; j++) { if (p[j].grades < p[j + 1].grades) { q = p[j]; p[j] = p[j + 1]; p[j + 1] = q; } else if (p[j].grades == p[j + 1].grades) { if (p[j].id > p[j + 1].id) { q = p[j]; p[j] = p[j + 1]; p[j + 1] = q; } } } } grades = p[m - 1].grades; int i = m; while (i < n && p[i].grades == grades) { i++; } printf("%d %d\n", grades, i); for (int j = 0; j < i; j++) { printf("%d %d\n", p[j].id, p[j].grades); } free(p); return 0; } ``` 修改后的代码使用了标准库头文件`<stdlib.h>`,并在动态分配内存时检查了分配是否成功。同时,将`m`乘以1.5时结果转换为整数,修正了找到排名时的循环条件,避免了数组越界。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值