Description
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output
For each problem instance, output consists of one line. This line should be one of the following three:
Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.
where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.
Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.
where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.
Sample Input
4 6 A<B A<C B<C C<D B<D A<B 3 2 A<B B<A 26 1 A<Z 0 0
Sample Output
Sorted sequence determined after 4 relations: ABCD. Inconsistency found after 2 relations. Sorted sequence cannot be determined.
该题题意明确,就是给定一组字母的大小关系判断他们是否能组成唯一的拓扑序列。是典型的拓扑排序,但输出格式上确有三种形式:
1.该字母序列有序,并依次输出;
2.该序列不能判断是否有序;
3.该序列字母次序之间有矛盾,即有环存在。
而这三种形式的判断是有顺序的:先判断是否有环(3),再判断是否有序(1),最后才能判断是否能得出结果(2)。注意:对于(2)必须遍历完整个图,而(1)和(3)一旦得出结果,对后面的输入就不用做处理了。
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int map[27][27];
int dis[27];
int di[27];
int n, m;
int topsort()
{
int c = 0;
int temp[27];
for(int i = 1; i <=n;i++)
temp[i] = dis[i];
int flag = 1,loc,m;
for(int i = 0; i < n; i++)
{
m = 0;
for(int j = 1; j <= n; j++)
{
if(temp[j]==0)
{
m++;
loc = j;
}
}
if(m == 0) return 0;
else if(m > 1) flag = -1;
di[c++]=loc;
temp[loc] = -1;
for(int j = 1; j <= n; j++)
{
if(map[loc][j]==1)
{
temp[j]--;
}
}
}
return flag;
}
int main()
{
char str[5];
while(~scanf("%d%d",&n,&m)&&(n+m))
{
memset(map,0,sizeof(map));
memset(dis,0,sizeof(dis));
memset(di,0,sizeof(di));
int sign = 0,s;
for(int i = 1; i <= m; i++)
{
scanf("%s",str);
if(sign)
{
continue;
}
int t,w;
t = str[0]-'A'+1;
w = str[2]-'A'+1;
map[t][w] = 1;
dis[w]++;
s = topsort();
if(s == 0)
{
printf("Inconsistency found after %d relations.\n",i);
sign = 1;
}
else if(s == 1)
{
printf("Sorted sequence determined after %d relations: ",i);
for(int j = 0; j < n; j++)
printf("%c",di[j]+'A'-1);
printf(".\n");
sign = 2;
}
}
if(!sign)
printf("Sorted sequence cannot be determined.\n");
}
return 0;
}