POJ 3734 Blocks 矩阵快速幂

题目链接

Description
Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.
Input
The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.
Output
For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.
Sample Input
2
1
2
Sample Output
2
6

题目大意:
给定N个方块排成一列。现要用红黄蓝绿四种颜色的油漆对方块进行染色,每个方块只能染成一种颜色。求红色方块和绿色方块的个数同时为偶数时的染色方案个数,输出模10007后的结果。

解题思路:
矩阵快速幂
下面是参考了《挑战程序设计》这本书得出的题目分析:
让我们试着从最左边开始染色,设染到第i个方块为止,红绿都是偶数的方案数为ai ,红绿只有一个是偶数的方案数为bi ,红绿都是奇数的方案数为ci
这样,染到第i+1个方块时,有以下递推式:

a i+1 = 2*a i + b i
b i+1 = 2*a i + 2*b i + 2*c i
c i+1 = b i + 2*c i

将上述递推式用矩阵表示如下:
[ a i + 1 b i + 1 c i + 1 ] = [ 2 1 0 2 2 2 0 1 2 ] [ a i b i c i ] \left[ \begin{matrix} a_{i+1} \\ b_{i+1} \\ c_{i+1} \end{matrix} \right] = \left[ \begin{matrix} 2 & 1 & 0 \\ 2 & 2 & 2 \\ 0 & 1 & 2 \end{matrix} \right] \left[ \begin{matrix} a_{i}\\ b_{i}\\ c_{i} \end{matrix} \right] ai+1bi+1ci+1=220121022aibici
由题意得,a1=2,b1=2,c1=0 ,因此可得:
[ a i b i c i ] = [ 2 1 0 2 2 2 0 1 2 ] i − 1 [ a 1 b 1 c 1 ] = [ 2 1 0 2 2 2 0 1 2 ] i − 1 [ 2 2 0 ] \left[ \begin{matrix} a_{i} \\ b_{i} \\ c_{i} \end{matrix} \right] = \left[ \begin{matrix} 2 & 1 & 0 \\ 2 & 2 & 2 \\ 0 & 1 & 2 \end{matrix} \right]^{i-1} \left[ \begin{matrix} a_{1}\\ b_{1}\\ c_{1} \end{matrix} \right] = \left[ \begin{matrix} 2 & 1 & 0 \\ 2 & 2 & 2 \\ 0 & 1 & 2 \end{matrix} \right]^{i-1} \left[ \begin{matrix} 2\\ 2\\ 0 \end{matrix} \right] aibici=220121022i1a1b1c1=220121022i1220

AC代码:

#include<iostream>
#include<stdio.h>
#include<vector>
using namespace std;
typedef long long ll;
typedef vector<int> vec;
typedef vector<vec> mat;
const int M = 10007;
mat mul(mat a, mat b) {
	mat c(a.size(), vec(b[0].size()));//a的行数  b的列数
	for (int i = 0; i < a.size(); i++) {
		for (int k = 0; k < b.size() ; k++) {
			for (int j = 0; j < b[0].size(); j++) {
				c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % M;
			}
		}
	}
	return c;
}
mat mod_pow(mat a, ll n) {
	mat b(a.size(), vec(a[0].size()));
	for (int i = 0; i < a.size(); i++) {
		b[i][i] = 1;
	}
	while (n > 0) {
		if (n & 1) b = mul(b, a);
		a = mul(a, a);
		n >>= 1;
	}
	return b;
}
int main() {
	int t; ll n;
	scanf("%d", &t);
	while (t--) {
		scanf("%lld", &n);
		mat a(3, vec(3));
		a[0][0] = 2; a[0][1] = 1; a[0][2] = 0;
		a[1][0] = 2; a[1][1] = 2; a[1][2] = 2;
		a[2][0] = 0; a[2][1] = 1; a[2][2] = 2;
		a = mod_pow(a, n - 1);
		ll ans = 0;
		ans += 2 * (a[0][0] + a[0][1]) % M;
		printf("%lld\n", ans);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值