算法竞赛入门经典 UVA Tree 中后序建树+DFS

题目链接

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.
Input
The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node.
Output
For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.
Sample Input
3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255
Sample Output
1
3
255

题目大意:
给定一棵二叉树的中序和后序遍历序列,找到一个叶子结点使得它到根的路径上的权和最小,如果有多解,该叶子结点本身的权值应该尽量小。

解题思路:
中后序建树+DFS

AC代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define maxn 10005
#define INF 0x3f3f3f3f
struct node {
	node *left;
	node *right;
	int c;
}tree[maxn];//静态内存分配数组
int num1[maxn]; int num2[maxn];
int cnt;//静态数组中已经分配的结点个数
node *creat() {//申请一个结点空间,返回指向其的指针
	tree[cnt].left = tree[cnt].right = NULL;//初始化左右儿子为空
	return &tree[cnt++];//返回指针,且计数器累加
}
node *build(int s1, int e1, int s2, int e2) {//由字符串的中序遍历和后序遍历还原树
	node *ret = creat();//为树的根结点申请空间
	ret->c = num2[e2];
	int rootidx;
	for (int i = s1; i <= e1; i++) {//查找该根结点字符在中序遍历中的位置
		if (num1[i] == num2[e2]) {
			rootidx = i;
			break;
		}
	}
	if (rootidx != s1) {//若左子树不为空
		ret->left = build(s1, rootidx - 1, s2, s2 + rootidx - s1 - 1);//递归还原左子树
	}
	if (rootidx != e1) {//若右子树不为空
		ret->right = build(rootidx + 1, e1, s2 + rootidx - s1, e2 - 1);//递归还原右子树
	}
	return ret;
}
int best, best_sum;
void dfs(node *t, int sum) {
	sum += t->c;
	if (t->left == NULL&&t->right == NULL) {//叶子结点
		if (sum == best_sum) {
			best = min(best, t->c);
		}
		else if (sum < best_sum) {
			best_sum = sum;
			best = t->c;
		}
		return;
	}
	if (t->left != NULL) {//左子树不为空
		dfs(t->left, sum);
	}
	if (t->right != NULL) {//右子树不为空
		dfs(t->right, sum);
	}
}
int main() {
	while (scanf("%d",&num1[0]) != EOF) {
		best = maxn; best_sum = INF;
		int k1 = 1, k2 = 0;
		while (true) {
			char ch = getchar();
			if (ch == '\n')break;
			scanf("%d", &num1[k1++]);
		}
		while (true) {
			scanf("%d", &num2[k2++]);
			char ch = getchar();
			if (ch == '\n')break;
		}
		cnt = 0;//将静态内存空间中已经使用的结点个数初始化为0
		node *t = build(0, k1 - 1, 0, k2 - 1);
		dfs(t, 0);
		cout << best << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
代码下载:完整代码,可直接运行 ;运行版本:2022a或2019b或2014a;若运行有问题,可私信博主; **仿真咨询 1 各类智能优化算法改进及应用** 生产调度、经济调度、装配线调度、充电优化、车间调度、发车优化、水库调度、三维装箱、物流选址、货位优化、公交排班优化、充电桩布局优化、车间布局优化、集装箱船配载优化、水泵组合优化、解医疗资源分配优化、设施布局优化、可视域基站和无人机选址优化 **2 机器学习和深度学习方面** 卷积神经网络(CNN)、LSTM、支持向量机(SVM)、最小二乘支持向量机(LSSVM)、极限学习机(ELM)、核极限学习机(KELM)、BP、RBF、宽度学习、DBN、RF、RBF、DELM、XGBOOST、TCN实现风电预测、光伏预测、电池寿命预测、辐射源识别、交通流预测、负荷预测、股价预测、PM2.5浓度预测、电池健康状态预测、水体光学参数反演、NLOS信号识别、地铁停车精准预测、变压器故障诊断 **3 图像处理方面** 图像识别、图像分割、图像检测、图像隐藏、图像配准、图像拼接、图像融合、图像增强、图像压缩感知 **4 路径规划方面** 旅行商问题(TSP)、车辆路径问题(VRP、MVRP、CVRP、VRPTW等)、无人机三维路径规划、无人机协同、无人机编队、机器人路径规划、栅格地图路径规划、多式联运运输问题、车辆协同无人机路径规划、天线线性阵列分布优化、车间布局优化 **5 无人机应用方面** 无人机路径规划、无人机控制、无人机编队、无人机协同、无人机任务分配 **6 无线传感器定位及布局方面** 传感器部署优化、通信协议优化、路由优化、目标定位优化、Dv-Hop定位优化、Leach协议优化、WSN覆盖优化、组播优化、RSSI定位优化 **7 信号处理方面** 信号识别、信号加密、信号去噪、信号增强、雷达信号处理、信号水印嵌入提取、肌电信号、脑电信号、信号配时优化 **8 电力系统方面** 微电网优化、无功优化、配电网重构、储能配置 **9 元胞自动机方面** 交通流 人群疏散 病毒扩散 晶体生长 **10 雷达方面** 卡尔曼滤波跟踪、航迹关联、航迹融合

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值