This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input2 1 2.4 0 3.2 2 2 1.5 1 0.5Sample Output
3 2 1.5 1 2.9 0 3.2
题目:求两个多项式相加
直接定义一个数组a[1001],下标代表指数,存的值代表系数,最后遍历数组输出即可
#include <iostream>
using namespace std;
double a[1001] = {0};
void input(int k){
int n;
double num;
for(int i = 0; i < k; i ++){
cin >> n >> num;
a[n] += num;
}
}
int main()
{
int k1, k2;
cin >> k1; input(k1);
cin >> k2; input(k2);
int N = 0;
for(int i = 0; i <= 1000; i ++){
if(a[i] != 0) N ++;
}
printf("%d", N);
for(int i = 1000; i >= 0; i --){
if(a[i] != 0) printf(" %d %.1f", i, a[i]);
}
return 0;
}