【HDU1312】A - Red and Black(bfs)


题目链接



There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13


题目意思就是从  @  开始可以走的  ‘.’  最多有多少个



#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 22;
typedef long long LL;
char s[MAX][MAX];
int vis[MAX][MAX],w,h,ans;
int fx[4]={0,0,1,-1};
int fy[4]={1,-1,0,0};

void dfs(int x,int y)
{
	vis[x][y]=1;
	ans++;
	for(int i=0;i<4;i++)   //可以走的四个方向
	{
		int xx=x+fx[i],yy=fy[i]+y;
		if(xx>=0&&yy>=0&&xx<h&&yy<w&&!vis[xx][yy]&&s[xx][yy]=='.')
		dfs(xx,yy);
	}
}


int main()
{
	while(~scanf("%d%d",&w,&h),h)
	{
		int x,y;
		memset(vis,0,sizeof(vis));     //初始化为0
		for(int i=0;i<h;i++)
		scanf("%s",s[i]);
		for(int i=0;i<h;i++)
			for(int j=0;j<w;j++)
			{
				if(s[i][j]=='@')    //找到@的位置
				x=i,y=j;
			}
		ans=0;
		dfs(x,y);
		printf("%d\n",ans);
	}
return 0;
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值