POJ 1979-Red and Black [dfs] 《挑战程序设计竞赛》2.1

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
….#.
…..#
……
……
……
……
……
#@…#
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
…@…
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

Japan 2004 Domesti

大意:

给定一个图,分成H*W个小块,两个小块之间有公共边则相连。问从给定位置出发所能到达的最多的小块个数。

题解:

标准的dfs

代码:

#include <iostream>
#include <cstring>
#define MAXN 30
using namespace std;

int a[MAXN][MAXN];
int W, H;
int x, y, ans;
char c;
int fx[] = {0, 1, 0, -1};
int fy[] = {1, 0, -1, 0};

void dfs(int x, int y) {
    a[x][y] = 0;
    ans++;
    for (int i = 0; i < 4; i++) {
        int tx = x + fx[i];
        int ty = y + fy[i];
        if (0 <= tx && tx < W && 0 <= ty && ty < H && a[tx][ty])
           dfs(tx, ty); 
    }    
}

int main() {
    while (cin >> H >> W) {
        x = y = 0;
        if (W == 0 && H == 0) break;
        memset(a, 0, sizeof(a));
        for (int i = 0; i < W; i++) {
            for (int j = 0; j < H; j++) {
                cin >> c;
                if (c == '.') a[i][j] = 1;
                else if (c == '#') a[i][j] = 0;
                else {
                    x = i;
                    y = j;
                    a[i][j] = 1;
                }
            }
        }

        ans = 0;
        dfs(x, y);
        cout << ans << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值