Wormholes POJ - 3259 spfa判断负环

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself 😃 .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2…M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2…M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1…F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
写过很多遍的题了,但是这次写还是忘了spfa判断负环的方法 所以写一篇博客

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f
const int N=2e5+7;
int fir[N],dis[N],co[N],vis[N],cnt;
struct node
{
    int x,y,w,to,next;
} e[N];
void init()
{
    memset(dis,inf,sizeof(dis));
    memset(vis,0,sizeof(vis));
    memset(fir,0,sizeof(fir));
}
void build(int x,int y,int z)
{
    e[cnt].next=fir[x];
    fir[x]=cnt;
    e[cnt].y=y;
    e[cnt++].w=z;

}
int spfa(int n)
{
    int u,i,y;
    memset(co,0,sizeof(co));
    queue<int> q;
    q.push(1);
    vis[1]=1;
    dis[1]=0;
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        vis[u]=0;//printf("--%d--\n",u);
        for(i=fir[u]; i; i=e[i].next)
        {

            y=e[i].y;
            if(dis[y]>dis[u]+e[i].w)
            {
                dis[y]=dis[u]+e[i].w;
                if(!vis[y])
                {
                    co[y]++;
                    if(co[y]>=n)//如果从1到点x(不包括x)总共有n个点,说明存在环
                        return 1;
                    q.push(y);
                    vis[y]=1;
                }
            }
        }
    }
    return 0;
}
int main()
{
    int t,n,m,z,w,x,y;
    scanf("%d",&t);
    while(t--)
    {
        init();
        cnt=1;
        scanf("%d%d%d",&n,&m,&w);
        while(m--)
        {
            scanf("%d%d%d",&x,&y,&z);
            build(x,y,z);
            build(y,x,z);
        }
        while(w--)
        {
            scanf("%d%d%d",&x,&y,&z);
            build(x,y,-z);
        }
        if(spfa(n))  printf("YES\n");
        else  printf("NO\n");
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值