Prime Ring Problem

Prime Ring Problem

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题目链接

#include<iostream>
#include<cstring>
using namespace std;
#define N 15

int n,ant = 0;
int a[N]={0},vis[N]={0};

int isPrime(int n){
	int ans = 0;
	for(int i =2; i < n; i++){
		if(n % i == 0){
			ans++;
			break;
		}
	}
	return ans;
}


void dfs(int pre,int dep){
	if(dep>=n && !isPrime(a[0] + a[n-1])){	
		for(int i = 0; i < n-1; i++ ){
			cout<<a[i]<<" ";
		}
		cout<<a[n-1]<<endl;
		return;
	}
	for(int i = 1; i < n; i++ ){
		if(vis[i]==0 && (dep==0 || !isPrime(a[pre]+i+1))){
			vis[i]=1;
			a[dep]=i+1;
			dfs(pre+1,dep+1);
			vis[i] = 0;
		}
	}
}

int main(){
	int num = 0;
	while(cin>>n){
		a[0] = 1;
		printf("Case %d:\n",++num);
		dfs(0,1); 
		printf("\n");
	}
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Fomharun

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值