PAT菜鸡进化史_乙级_1032

PAT菜鸡进化史_乙级_1032

为了用事实说明挖掘机技术到底哪家强,PAT 组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:

输入在第 1 行给出不超过 10​5​​ 的正整数 N,即参赛人数。随后 N 行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从 1 开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:

在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。

输入样例:

6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例:

2 150

思路:

开个数组存一下学校总分就可以啦!

Code:

#include <iostream>

int main(){
    using namespace std;
// input the number of participator
    int n;
    cin >> n;
// input the scores
    int max_school = 0, school, score;
    int school_score[100001] = {0};
    for (int i = 0; i < n; i++){
        cin >> school >> score;
    // update the school
        max_school = school > max_school ? school : max_school;
        school_score[school] += score;
    }
// output the result
    int output = 0;
    for (int i = 1; i <= max_school; i++)
        output = school_score[i] > school_score[output] ? i : output;
    cout << output << " " << school_score[output] << endl;

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值