PAT菜鸡进化史_乙级_1054

PAT菜鸡进化史_乙级_1054

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y

输入样例1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例2:

2
aaa -9999

输出样例2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

思路:

主要需要注意的就是只有一个数字的时候number后面的s不要加上去了
以及.3 3.之类小数点在最边上的行为是被允许的(这个有够坑的。。)

Code:

#include <iostream>
#include <string>
#include <iomanip>

int main(){
    using namespace std;
// input the total number
    int n;
    cin >> n;
// count the legal number and sum all of them
    int legal = 0;
    double sum = 0;
    string str;
    for (int i = 0; i < n; i++){
        cin >> str;
        int sign = 1;
        if (str[0] == '-'){
            str = str.substr(1, str.size() - 1);
            sign = -1;
        }
        if (to_string(stod("1" + str)).substr(0, str.size() + 1) == ("1" + str) &&    // if the input is a number
            stod(str) <= 1000 &&                                                      // if the input is in the section
            ((int(str.find('.')) >= (int(str.size()) - 3) && int(str.find('.')) <= (int(str.size()) - 1)) || str.find('.') == string::npos)){     // if there is no more than 2 number behind the point
                sum += stod(str) * sign;
                legal++;
        }else {
            cout << "ERROR: ";
            if (sign == -1)
                cout << "-";
            cout << str << " is not a legal number" << endl;
        }
    }
// display the answer
    cout << "The average of " << legal;
    if (legal == 1)
        cout << " number ";
    else
        cout << " numbers ";
    cout << "is ";
    if (legal == 0)
        cout << "Undefined" << endl;
    else
        cout << setiosflags(ios::fixed) << setprecision(2) << sum / legal << endl;

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值