HDOJ-1058 Humble Numbers(动态规划)

链接:HDOJ-1058

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.


题目大意:

因子只有2,3,5,7的数称为丑数(1也是丑数),找到第N个丑数(N<=5842)


分析:

思路不难想,对已有的所有数*2,*3,*5,*7,从中选出能放在下一位的数。
但是知道了这个却一直想不出好的dp方法。。。 后来看到别人的状态转移方程豁然开朗。。。
如下:

dp[i] = min( dp[two] * 2 , dp[three] * 3 , dp[five] * 5 , dp[seven] * 7 )

two,three,five,seven是*2,*3,*5,*7 进行到第几个数的位置标记,这样保证了已有的所有数都进行 *2,*3,*5,*7而且只进行一次,同时进行min比对。
得出的 dp[i] 会等于其中某一个结果(或多个结果:*2,*3,*5,*7可能有相同值),就让对应位置标记+1,这样同时能保证进行min对比的都是相对小的值。

此外,就是这题输出的坑,结尾为1,2,3并且结尾不是11,12,13的N后面要加上"st",“nd”,“rd”,其他的加"th"。


以下代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	int dp[6000];
	int i,two=1,three=1,five=1,seven=1;
	dp[1]=1;
	for(i=2;i<=5842;i++)
	{
		dp[i]=min(min(dp[two]*2,dp[three]*3),min(dp[five]*5,dp[seven]*7));
		if(dp[i]==dp[two]*2)
			two++;
		if(dp[i]==dp[three]*3)
			three++;
		if(dp[i]==dp[five]*5)
			five++;
		if(dp[i]==dp[seven]*7)
			seven++;
	}
	int N;
	while(scanf("%d",&N)&&N!=0)
	{
		printf("The %d",N);
		if(N%10==1&&N%100!=11)
			printf("st");
		else if(N%10==2&&N%100!=12)
			printf("nd");
		else if(N%10==3&&N%100!=13)
			printf("rd");
		else
			printf("th");
		printf(" humble number is %d.\n",dp[N]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值