HDOJ题目1058Humble Numbers(数学,丑数)

57 篇文章 1 订阅

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17104    Accepted Submission(s): 7434


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

Source
 思路: 我们已经有第一个丑数f[1] = 1,那么就设一个游标i=1指向f[1],然后依次将2,3,5,7与f[i]相乘,即我们可以得到2,3,5,7,然后依次将这些丑数加入到f[i]中,f[2] = 2, f[3] = 3, f[4] = 5, f[5] = 7,接着讲游标i++指向2,再分别于2,3,5,7相乘,即可以得到f[6] = 4, f[7] = 6, f[8] = 10, f[9] = 14。按照这种算法算下去,直到丑数的个数累计到了5842个
ac代码
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int min(int a,int b)
{
        if(a>b) return b;
        else return a;
}
int main()
{
        long int a[5888];
        long int s1,s2,s3,s4,t,n;
        s1 = s2 = s3 = s4 =1;
        a[1] = 1;
        for(int i=2;i<5888;i++)
        {
                t = min(min(min(a[s1]*2,a[s2]*3),a[s3]*5),a[s4]*7);
                if(t == a[s1]*2) s1++;
                if(t == a[s2]*3) s2++;
                if(t == a[s3]*5) s3++;
                if(t == a[s4]*7) s4++;
                a[i] = t;
        }
        while(scanf("%ld",&n))
        {
          if(n==0)
          break;
          if(n%10==1&&n%100!=11)
          printf("The %ldst humble number is %ld.\n",n,a[n]);
          else if(n%10==2&&n%100!=12)
          printf("The %ldnd humble number is %ld.\n",n,a[n]);
          else if(n%10==3&&n%100!=13)
          printf("The %ldrd humble number is %ld.\n",n,a[n]);
          else
          printf("The %ldth humble number is %ld.\n",n,a[n]);
        }
        return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值