H - Cow Contest(全源最短路,Floyd算法)

链接:Cow Contest

N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2



题意:

共N头牛(编号1 ~ N),给出M组A、B(A ≠ B),表示A能力水平高于B,将这N头牛按能力水平排名,问 根据这M组数据 可以确定名次的牛有多少只



分析:

可以发现只要某一头牛能和 除自己以外的所有其他牛 确定能力水平的大小关系,那么它的名次就确定了。(即比某些牛水平高,比某些牛水平低,这样就能确定名次了)

创建一个数组dis[maxn][maxn],若dis[u][v]==1,表示u水平比v高;若dis[u][v]==INF,表示u、v之间水平大小关系未确定。



以下代码:

#include<cstdio>
#include<climits>
#include<algorithm>
#include<cstring>
#define LL long long
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=110;
int N,M,dis[maxn][maxn];
void floyd()
{
	for(int k=1;k<=N;k++)          //枚举结点 k
	{
		for(int u=1;u<=N;u++)       //以 k为中介点,枚举所有结点对 u,v
		{
			for(int v=1;v<=N;v++)
			{
				if(dis[u][k]!=INF&&dis[k][v]!=INF&&dis[u][k]+dis[k][v]<dis[u][v])
					dis[u][v]=dis[u][k]+dis[k][v];
			}
		}
	}
}
int main()
{	
	while(~scanf("%d %d",&N,&M))
	{
		memset(dis,0x3f,sizeof(dis));
		for(int i=1;i<=M;i++)
		{
			int u,v;
			scanf("%d %d",&u,&v);
			dis[u][v]=1;
		}
		floyd();
		int ans=0;
		for(int k=1;k<=N;k++)
		{
			bool flag=true;
			for(int i=1;i<=N;i++)
			{
				if(k==i)
					continue;
				if(dis[i][k]==INF&&dis[k][i]==INF)
				{                  //若不能判断 i,k的水平高低
					flag=false;
					break;
				}
			}
			if(flag)
				ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值