POJ - 3281 Dining(匹配问题,网络流)

题目链接:POJ - 3281 Dining

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: N, F, and D
Lines 2… N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3


题意:

农夫为他的 N (1 ≤ N ≤ 100) 牛准备了 F (1 ≤ F ≤ 100)种食物和 D (1 ≤ D ≤ 100) 种饮料。每头牛都有各自喜欢的食物和饮料,而每种食物或饮料只能分配给一头牛。最多能有多少头牛可以同时得到喜欢的食物和饮料?



分析:

网络流题关键的就是建图了,例如 s -> 食物 -> 牛 -> 饮料 -> t,但是要注意这也可能会有一头牛拿到多对喜欢的食物和饮料,所以要把图拆为 s -> 食物 -> 牛 -> 牛 -> 饮料 -> t,其中 牛 -> 牛是同一头牛到同一头牛,设定容量为1,就可以了。



以下代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<stack>
#include<set>
#include<vector>
#include<algorithm>
#define LL long long
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=(100+7)*4;
const int s=0;
const int t=maxn-1;
int N,F,D,G[maxn][maxn];
int pre[maxn],mi;
bool BFS()
{
    bool vis[maxn]={false};
    mi=INF;
    memset(pre,-1,sizeof(pre));
    queue<int> q;
    q.push(s);
    vis[s]=true;
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        for(int v=0;v<=maxn-1;v++)
        {
            if(!vis[v]&&G[u][v]!=0)
            {
                mi=min(mi,G[u][v]);
                pre[v]=u;
                if(v==t)
                    return true;
                q.push(v);
                vis[v]=true;
            }
        }
    }

    return false;
}
int EK()
{
    int ans=0;
    while(BFS())
    {
        for(int i=t;pre[i]!=-1;i=pre[i])
        {
            G[pre[i]][i]-=mi;
            G[i][pre[i]]+=mi;
        }
        ans+=mi;
    }
    return ans;
}
int main()
{
    memset(G,0,sizeof(G));
    scanf("%d %d %d",&N,&F,&D);
    for(int f=1;f<=F;f++)
        G[s][f]=1;
    for(int n=1;n<=N;n++)
        G[F+n][F+N+n]=1;
    for(int d=1;d<=D;d++)
        G[F+N+N+d][t]=1;
    for(int k=1;k<=N;k++)
    {
        int Fi,Di,f,d;
        scanf("%d %d",&Fi,&Di);
        for(int i=0;i<Fi;i++)
        {
            scanf("%d",&f);
            G[f][F+k]=1;
        }
        for(int i=0;i<Di;i++)
        {
            scanf("%d",&d);
            G[F+N+k][F+N+N+d]=1;
        }
    }
    printf("%d",EK());
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值