C++面向对象程序设计 第二周 类和对象

一、 Week2_005 编程填空:学生信息处理程序

输入
输入数据为一行,包括:
姓名,年龄,学号,第一学年平均成绩,第二学年平均成绩,第三学年平均成绩,第四学年平均成绩。
其中姓名为由字母和空格组成的字符串(输入保证姓名不超过20个字符,并且空格不会出现在字符串两端),年龄、学号和学年平均成绩均为非负整数。信息之间用逗号隔开。
输出
输出一行数据,包括:
姓名,年龄,学号,四年平均成绩。
信息之间用逗号隔开。
样例输入
Tom Hanks,18,7817,80,80,90,70
样例输出
Tom Hanks,18,7817,80

#include "stdafx.h"
//#pragma warning(disable: 4996)
#include <iostream>
using namespace std;
#include <string>
#include<cstring>
#include <cstdio>
#include <cstdlib>
class Student
{
private:
        char name[20];
        int id;
        int age;
        int score[4];
        double average;
public:
        void input() {
               char buf[200];
               cin.getline(buf, 200);//好几次数组越界,但是VS判不出来……
               char *p = strtok(buf, ",");
               strcpy(name,p);
               p = strtok(NULL, ",");
               age = atoi(p);
               p = strtok(NULL, ",");
               id = atoi(p);
               for (int i = 0; i < 4; i++)
               {
                       p = strtok(NULL, ",");
                       score[i] = atoi(p);
               }
               }
        void calculate() {
               double sum=0;
               for (int i = 0; i < 4; i++)
               {
                       sum += score[i];
               }
               average = sum / 4;
        }
        void output() {
               cout << name << "," << age << "," << id << "," << average << endl;
        }
};
int main() {
        Student student;        // 定义类的对象
        student.input();        // 输入数据
        student.calculate();    // 计算平均成绩
        student.output();       // 输出数据
}

二、Week2_006 奇怪的类复制

输入

输出
9
22
5
样例输入
None
样例输出
9
22
5

#include "stdafx.h"


#include <iostream>
using namespace std;
class Sample {
public:
        int v;
        Sample(){}
        Sample(int a) {
               v = a;
        }
        Sample(const Sample & a) {
               v = a.v+2;
        }
        // 在此处补充你的代码
};
void PrintAndDouble(Sample o)
{
        cout << o.v;
        cout << endl;
}
int main()
{
        Sample a(5);
        Sample b = a;
        PrintAndDouble(b);
        Sample c = 20;
        PrintAndDouble(c);
        Sample d;
        d = a;
        cout << d.v;
        return 0;
}

三、Week2_007 返回什么才好呢

输入
多组数据,每组一行,是整数 m 和 n
输出
先输出一行:
123
然后,对每组数据,输出两行,第一行是m,第二行是n
样例输入
2 3
4 5
样例输出
123
2
3
4
5

#include "stdafx.h"

#include <iostream>
using namespace std;
class A {
public:
        int val;

        A(int
               // 在此处补充你的代码
               v = 123) {
               val = v;
        }
        A& GetObj() {
               return *this;
        }
        // 在此处补充你的代码

};
int main()
{
        int m, n;
        A a;
        cout << a.val << endl;
        while (cin >> m >> n) {
               a.GetObj() = m;
               cout << a.val << endl;
               a.GetObj() = A(n);
               cout << a.val << endl;
        }
        return 0;
}

四、Week2_008 超简单的复数类

输入

输出
3+4i
5+6i
样例输入

样例输出
3+4i
5+6i

#include "stdafx.h"

#include <iostream>
#include <cstring>
#include <cstdlib>
using namespace std;
class Complex {
private:
        double r, i;
public:
        void Print() {
               cout << r << "+" << i << "i" << endl;
        }
        // 在此处补充你的代码
        Complex() {}
        Complex (const char * p  ) {
               r = p[0] - '0';   //竟然可以这么简单!!!!!
               i = p[2] - '0';
        }

        // 在此处补充你的代码
};
int main() {
        Complex a;
        a = "3+4i"; a.Print();
        a = "5+6i"; a.Print();
        return 0;
}

五、Week2_009 哪来的输出

输入

输出
2
1
样例输入

样例输出
2
1

#include "stdafx.h"

#include <iostream>
using namespace std;
class A {
public:
        int i;
        A(int x) { i = x; }
        // 在此处补充你的代码
        ~A(){
               cout << i << endl;
        }
        // 在此处补充你的代码
};
int main()
{
        A a(1);
        A * pa = new A(2);
        delete pa;
        return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值