hdu 1003 dp

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

Sample Output
 Case 1:
 14 1 4

Case 2:
7 1 6
本来以为此题很简单,AC应该很容易,结果提交错了几次,格式不对,或者没全面考虑。。
思路很简单: 动态规划。 因为是连续和的最大值,所以一直累加,若为负数,则令为0,重新选择,选择几个值保持最大值,下标。
AC代码:
#include<iostream>
#include<stdio.h>
using namespace std;
int a[100010];
int main()
{
int test,Count=0,n,i,j,max;
scanf("%d",&test);
while(test--)
{
int temp=0,start=1,end=1,p=1;
max=-1010;
Count++;
scanf("%d",&n);
for(i=1;i<=n;++i)
{
scanf("%d",&a[i]);
temp+=a[i];
if(temp>max) 
        { max=temp; end=i;start=p;}
   if(temp<0) { temp=0;p=i+1;}            //顺序不能换~~ 哭,,,
}
      printf("Case %d:\n",Count);
printf("%d %d %d\n",max,start,end);
if(test)
cout<<endl;
}
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值