模拟 | POJ1573.Robot Motion

模拟 | POJ1573.Robot Motion

LInk: Robot Motion
Description
img
A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word “step” is always immediately followed by “(s)” whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

Source
Mid-Central USA 1999

题意
有一个AXB大小的网格,机器人从最北边的某一个位置出发,根据每个网格的指令移动,要求求出机器人走出网格的步数或者走入死循环前和死循环的步数。

思路
分别用 char grid[12][12]存储指令和int visit[12][12]存储机器人来到当前网格所走的步数(同时能够判断根据网格是否经过来判断是否进入死循环)。首先计算下一个将要移动的位置( newx, newy ),每走一步,计数值自增1
若下一个位置再网格之外,则输出计数值
若下一个位置在网格内,且曾经没有走过,那么将机器人的坐标(x, y)移动到新位置( newx, newy )。并且将( newx, newy )的visit值设为cnt,表示从起点走到新位置的步数。否则,出现了死循环,进入循环前的步数就是visit存储的值,循环内步数为总cnt值减去visit值。

小贴士
1.用数组dx[4] = {-1, 0, 1, 0};dy[4] = {0, 1, 0, -1};进行坐标向 N W S W方向的移动
2.方向用0,1,2,3表示
用map数据类型将字符’N’, ‘E’, ‘S’, 'W’映射到0,1,2,3

代码 这段代码不知道为什么WA,逻辑上还没发现什么错误,样例通过了,可是就是WA,如果你发现了我代码的问题还请留言,哈哈哈。

#include <iostream>
#include <map>
#include <cstring>

using namespace std;

char grid[12][12];
int visit[12][12];

int row, col, col_s;

int dx[4] = {-1, 0, 1, 0};   //方向依次为N E S W
int dy[4] = {0, 1, 0, -1};

map<char, int> mp;

bool isExit( int x, int y )
{
    if( x <= 0 || x > row || y <= 0 || y > col )
        return true;
    else
        return false;
}

int main()
{
    mp['N'] = 0;
    mp['E'] = 1;
    mp['S'] = 2;
    mp['W'] = 3;
    char c;
    while( cin >> row >> col >> col_s && row !=0 )
    {
        //初始化
        memset(visit, 0, sizeof(visit));
        for( int i = 1; i <= row; i++ )
            for( int j = 1; j <= col; j++ )
            {
                cin >> c;
                grid[i][j] = c;
            }
        int x = 1, y = col_s;
        int cnt = 0;
        int newx, newy;
        while( true )
        {
            newx = x + dx[mp[grid[x][y]]];
            newy = y + dy[mp[grid[x][y]]];
            cnt++;
            if( isExit(newx, newy) )
            {
                cout << cnt << " step(s) to exit" << endl;
                break;
            }
            else if( !visit[newx][newy] )
            {
                visit[newx][newy] = cnt;
                x = newx;
                y = newy;
            }
            else
            {
                cout << visit[newx][newy] << " step(s) before a loop of " << cnt-visit[newx][newy] << " step(s)" << endl;
                break;
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值