【POJ 1222】EXTENDED LIGHTS OUT

EXTENDED LIGHTS OUT

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7333 Accepted: 4792
Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.

Note:
1. It does not matter what order the buttons are pressed.
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
Write a program to solve the puzzle.
Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.
Output

For each puzzle, the output consists of a line with the string: “PUZZLE #m”, where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1’s indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.
Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0
Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1
Source

Greater New York 2002

高斯消元解异或方程组。

首先把数组标号为 id[i][j] ,后文所说的第 k 个就是指他的标号id[i][j]=k

①我们用 a[i][j] 表示读入的方格;

f[i][j] 表示第 i 个方格对第j个方格有影响,即你对第 i 个方格执行开关操作时,j方格也被操作了( j i的十字形区域内);

③最后的答案数组为 ans[i] ans[i]=1 表示第 i 个方格被执行操作了;

tot=nm

对于一个方格 (i,j) ,最后状态为 0 ,设id[i][j]=k,我们可以列出这样的式子

a[i][j]+f[k][1]ans[1]+f[k][2]ans[2]+...f[k][tot]ans[tot]=0(mod2)

因为对方程 mod 2 相当于取异或,我们可以把a[i][j]移到右边,方程变为:

f[k][1]ans[1]+f[k][2]ans[2]+...f[k][tot]ans[tot]=a[i][j](mod2)

那么现在有 tot 个方程, tot 个未知数,高斯消元就可以直接出来了~

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#define N 5
#define M 6
using namespace std;
int a[35][35],ans[35],id[10][10],d[15][3];
void Gauss(int n,int m)
{
    for (int i=1;i<=n;i++)
    {
        int j;
        for (j=i;j<=n&&!a[i][j];j++);
        if (j==n+1) continue;
        if (i!=j)
            for (int k=i;k<=m;k++)
                swap(a[i][k],a[j][k]);
        for (int j=i+1;j<=n;j++)
            if (a[j][i])
                for (int k=i;k<=m;k++)
                    a[j][k]^=a[i][k];
    }
    for (int i=n;i;i--)
    {
        for (int j=n;j>i;j--)
            a[i][m]^=(a[i][j]*a[j][m]);
        ans[i]=a[i][m];
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    int cnt=0;
    for (int i=1;i<=N;i++)
        for (int j=1;j<=M;j++)
            id[i][j]=++cnt;
    d[0][1]=d[0][2]=0;
    d[1][1]=d[2][1]=0,d[1][2]=1,d[2][2]=-1;
    d[3][2]=d[4][2]=0,d[3][1]=1,d[4][1]=-1;
    for (int t=1;t<=T;t++)
    {
        memset(a,0,sizeof(a));
        printf("PUZZLE #%d\n",t);
        for (int i=1;i<=N;i++)
            for (int j=1;j<=M;j++)
                for (int k=0;k<=4;k++)
                {
                    int p=id[i+d[k][1]][j+d[k][2]];
                    if (p) a[id[i][j]][p]=1;
                    else a[id[i][j]][p]=0;
                }
        for (int i=1;i<=N;i++)
            for (int j=1;j<=M;j++)
                scanf("%d",&a[id[i][j]][31]);
        Gauss(cnt,cnt+1);
        int now=0;
        for (int i=1;i<=N;i++)
        {
            printf("%d",ans[++now]);
            for (int j=2;j<=M;j++)
                printf(" %d",ans[++now]);
            printf("\n");
        }
    }
    return 0;
}

这里写图片描述

感悟:

WA是因为没有清零a数组,导致一些本来是0的在之后变成1了。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值