poj 2386 Lake Counting

4 篇文章 0 订阅
Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41379 Accepted: 20528

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

统计大水坑个数,W为小水坑,用dfs来做.

#include <iostream>
using namespace std;
char a[105][105];
void dfs(int x,int y,int n,int m)
{
	a[x][y]='.';                   //先把此点转化掉,然后开始寻找符合条件范围的点,找到后开始递归搜索 
	int dx,dy;
	for(dx=-1; dx<=1; dx++)
	{
		for(dy=-1; dy<=1; dy++)
		{
			int nx=x+dx,ny=y+dy;
			if(a[nx][ny]=='W' && nx<n && ny<m && nx>=0 && ny>=0)
			{
				dfs(nx,ny,n,m);
			}
		}
	}
	return ;
}
int main()
{
	int n,i,j,m;
	cin>>n>>m;
	for(i=0; i<n; ++i)
	{
		for(j=0; j<m; ++j)
		{
			cin>>a[i][j];
		}
	}
	int ans=0;
	for(i=0; i<n; ++i)
	{
		for(j=0; j<m; ++j)
		{
			if(a[i][j]=='W')  //从头开始找到W则开始深搜 
			{
				dfs(i,j,n,m);
				ans++;
			}
		}
	}
	cout<<ans<<endl;
	return 0;   
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值