2192 Zipper

描述

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.



For example, consider forming "tcraete" from "cat" and "tree":


String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":


String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

输入

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.



For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.
输出For each data set, print:


Data set n: yes


if the third string can be formed from the first two, or


Data set n: no


if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

样例输入

3

cat tree tcraete
cat tree catrtee
cat tree cttaree


样例输出

Data set 1: yes

Data set 2: yes

Data set 3: no

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
char a[1000],b[1000],c[1000];
int len1,len2,len3,ok;
int dfs(int x,int y,int z);
int main()
{
	int n;
	cin>>n;
	for(int i=1;i<=n;i++)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		memset(c,0,sizeof(c));
		cin>>a>>b>>c;
		 len1=strlen(a),len2=strlen(b),len3=strlen(c);
		cout<<"Data set "<<i<<": ";
		ok=0;
		dfs(0,0,0);
		if(ok==1) cout<<"yes"<<endl;
		else cout<<"no"<<endl;
	}
	return 0;
}
int dfs(int x,int y,int z)
{
	if(z==len3) 
	{
		ok=1;
	return 0;}
	else
	{
		if(a[x]==c[z]) dfs(x+1,y,z+1);
	    if(b[y]==c[z]) dfs(x,y+1,z+1);
		if(a[x]!=c[z]&&b[y]!=c[z])
		{
			return 0;
		}
	}
}
//dp
/*
#include <iostream>  
#include <cstdio>  
#include <cstring>  
using namespace std;  
int main(){  
    int n;  
    cin>>n;  
    for(int i=1;i<=n;i++){  
        char a[250];  
        char b[250];  
        char c[550];  
    scanf("%s%s%s",a,b,c);  
    int la=strlen(a);  
    int lb=strlen(b);  
    int lc=strlen(c);  
    int dp[250][250];  
    memset(dp,0,sizeof(dp));  
    dp[0][0]=1;  
    if(a[0]==c[0])dp[1][0]=1;  
    if(b[0]==c[0])dp[0][1]=1;  
    for(int j=0;j<=la;j++){  
        for(int k=0;k<=lb;k++){  
            if(k>=1&&c[k+j-1]==b[k-1])  
                dp[j][k]=dp[j][k]||dp[j][k-1];  
            if(j>=1&&c[k+j-1]==a[j-1])  
                dp[j][k]=dp[j][k]||dp[j-1][k];  
        }  
    }  
    if(dp[la][lb])cout<<"Data set "<<i<<": yes"<<endl;  
    else   
       cout<<"Data set "<<i<<": no"<<endl;  
    }  
    return 0;  
}        
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值