(甲)1003 Emergency

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

key:

最短路问题,完全参考算法笔记写的。。

#include <iostream>
#include <algorithm>
#include <cstring>
#define MAXV 1000  //最大顶点数 
#define INF 0x3fffffff  //无穷大 
using namespace std;
int n,G[MAXV][MAXV],num[MAXV]= {0};  //n为顶点数,G为邻接矩阵,num记录最短路径数 
int d[MAXV],weight[MAXV],w[MAXV]= {0}; //d记录最短距离,weight记录点的权重,w记录最大点权之和 
bool vis[MAXV]= {false};  //开始时候所有点未被访问 

void Dijkstra(int s)  //s为起点 
{
	fill(d,d+MAXV,INF);
	d[s]=0;
	num[s]=1;
	w[s]=weight[s];
	for(int i=0; i<n; i++)
		{
			int u=-1,MIN=INF;  
			for(int j=0; j<n; j++)  //找到未访问顶点中d最小的 
				{
					if(vis[j]==false&&d[j]<MIN)
						{
							u=j;
							MIN=d[j];
						}
				}
			if(u==-1) return;  //剩下的顶点与起点均不连通 
			vis[u]=true;  //标记为已经访问 
			for(int v=0; v<n; v++)
				{
					if(vis[v]==false&&G[u][v]!=INF&&d[u]+G[u][v]<d[v])  //顶点v未被访问且u能到达v且u作为中介点可以使d更优 
						{
							d[v]=d[u]+G[u][v];
							w[v]=w[u]+weight[v];
							num[v]=num[u];
						}
					else if(vis[v]==false&&G[u][v]!=INF&&d[u]+G[u][v]==d[v]) //长度相等时 
						{
							num[v]+=num[u];
							if(w[u]+weight[v]>w[v])  //优化最大点权 
								w[v]=w[u]+weight[v];
						}
				}
		}

}
int main()
{
	int x,start,end,t,u,v;
	cin>>n>>x>>start>>end;
	fill(G[0],G[0]+MAXV*MAXV,INF);
	for(int i=0; i<n; i++)
		{
			cin>>weight[i];
		}
	while(x--)
		{
			cin>>u>>v>>t;
			G[u][v]=t;
			G[v][u]=t;
		}
	Dijkstra(start);
	cout<<num[end]<<" "<<w[end];
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值