PAT A1077 Kuchiguse (20分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805390896644096

题目描述
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

Itai nyan~ (It hurts, nyan~)

Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

输入
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

输出
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

样例输入
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

样例输出
nyan~

代码

#include <cstdio>
#include <iostream>
#include <string>
#include <algorithm>

using namespace std;

int main() {
	int n, min = 300, num = 0, len;
	string str[110], temp;
	bool flag;
	scanf("%d", &n);
	getchar();
	for(int i = 0; i < n; i++) {
		getline(cin, str[i]);
		len = str[i].size();
		if(len < min)
			 min = len;
		reverse(str[i].begin(),str[i].end());
	}
	for(int i = 0; i < min; i++) {
		flag = true;
		for(int j = 1; j  < n; j++) {
			if(str[j][i] != str[0][i]) {  
				flag = false;
				break;
			}
		}
		if(flag)	{
			num++;
			temp += str[0][i];
		}											
		else
			break;
	}
	if(num == 0)
		printf("nai\n");
	else {
			reverse(temp.begin(), temp.end());
			cout<<temp<<endl;
		
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值