HDU 1021 Fibonacci Again

FibonacciAgain

TimeLimit: 2000/1000 MS (Java/Others)    Memory Limit:65536/32768 K (Java/Others)
Total Submission(s): 50623    Accepted Submission(s): 23965

ProblemDescription

There are another kind of Fibonaccinumbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

 

 

Input

Input consists of a sequence of lines,each containing an integer n. (n < 1,000,000).

 

 

Output

Print the word "yes" if 3divide evenly into F(n).

Print the word "no" if not.

 

 

SampleInput

0

1

2

3

4

5

 

 

SampleOutput

no

no

yes

no

no

no



这儿有斐波那契数字,F(0) =7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

输入由一列数列组成,每次都包含一个整数n,

如果3能够整除F(n)则输出” yes”,否则就输出”no”

 

输入:

0

1

2

3

4

5

 

输出:

no

no

yes

no

no

no


其实也就是几行代码的事,既然数学问题能够轻松解决,那就不要麻烦电脑了,要的就是处理问题的效率。

让电脑计算前几位数字,找出规律 2,6,10,14……

#include<stdio.h>
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		if((n-2)%4==0) printf("yes");
		else printf("no");
		printf("\n");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值