又见GCD |
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) |
Total Submission(s): 2573 Accepted Submission(s): 1273 |
Problem Description
有三个正整数a,b,c(0<a,b,c<10^6),其中c不等于b。若a和c的最大公约数为b,现已知a和b,求满足条件的最小的c。
|
Input
第一行输入一个n,表示有n组测试数据,接下来的n行,每行输入两个正整数a,b。
|
Output
输出对应的c,每组测试数据占一行。
|
Sample Input
2 6 2 12 4 |
Sample Output
4 8 |
思路:
a=i*b b=b c=j*b
找到最小的j,使得j和i没出了1之外的公约数就可以
菜鸟级的原创代码,已AC。若有可提高之处欢迎指导
#include<stdio.h>
#include<math.h>
int hasCommonFactor(int x,int y)
{
int s =x > y ? y : x;
for (int i = 2; i <= s;i++)
if (x%i + y%i == 0)
return true;
return false;
}
int another(int a, int b)
{
int k = a / b,i=1;
while(i++)
if (!hasCommonFactor(k, i))
return i*b;
}
int main()
{
int n, a, b;
scanf("%d", &n);
while (n--)
{
scanf("%d %d", &a, &b);
printf("%d\n", another(a, b));
}
return 0;
}