POJ 2421 Constructing Roads

Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output
179


题意:
有N个村庄,编号从1到N。现需要在这N个村庄之间修路,使得任何两个村庄之间都可以连通。称A、B两个村庄是连通的,当且仅当A与B有路直接连接,或者存在村庄C,使得A和C两村庄之间有路连接,且C和B之间有路连接。已知某些村庄之间已经有路直接连接了,试修建一些路使得所有村庄都是连通的、且修路总长度最短。
分析:
最小生成树问题,已经修好路的村庄标记一下,然后再用Kruskal算法求解。


#include<algorithm>
#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=110;
int t,n,m,ans,f[maxn];
struct node
{
    int x,y,val;
}a[maxn*maxn];
bool cmp(node c,node d)
{
    return c.val<d.val;
}
int fnd(int x)
{
    if(f[x]!=x)
        f[x]=fnd(f[x]);
    return f[x];
}
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        f[i]=i;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        {
            int tmp;
            scanf("%d",&tmp);
            m++;
            a[m].x=i;
            a[m].y=j;
            a[m].val=tmp;
        }
    sort(a+1,a+m+1,cmp);
    scanf("%d",&t);
    while(t--)
    {
        int t1,t2;
        scanf("%d%d",&t1,&t2);
        f[fnd(t2)]=fnd(t1);
    }
    for(int i=1;i<=m;i++)
        if(fnd(a[i].x)!=fnd(a[i].y))
        {
            f[fnd(a[i].x)]=fnd(a[i].y);
            ans+=a[i].val;
        }
    printf("%d\n",ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值