POJ 3518 Prime Gap

Description
The sequence of n − 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n. For example, ‹24, 25, 26, 27, 28› between 23 and 29 is a prime gap of length 6.
Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.
Input
The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.
Output
The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.
Sample Input
10
11
27
2
492170
0
Sample Output
4
0
6
0
114


给出整数n,求他前一个素数和后一个素数的差。如果n是素数 输出0。
先用素数筛,再二分答案。


#include<algorithm>
#include<iostream>
#include<cstdio>
using namespace std;
int cnt,pri[1300009];
bool vis[1300009];
void euler(int m)
{
    vis[1]=1;
    for(int i=2;i<=m;i++)
    {
        if(!vis[i])
            pri[++cnt]=i;
        for(int j=1;i*pri[j]<=m&&j<=cnt;j++)
        {
            vis[i*pri[j]]=1;
            if(i%pri[j]==0)
                break;
        }
    }
}
int bin(int x)
{
    int ans=lower_bound(pri+1,pri+cnt+1,x)-pri;
    return pri[ans]-pri[ans-1];
}
int main()
{
    euler(1299709);
    int x;
    while(scanf("%d",&x)&&x)
    {
        if(vis[x])
            printf("%d\n",bin(x));
        else
            printf("0\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值