POJ 2282 The Counting Problem

Description

Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit. For example, if a = 1024 and b = 1032, the list will be 
1024 1025 1026 1027 1028 1029 1030 1031 1032

there are ten 0's in the list, ten 1's, seven 2's, three 3's, and etc.

Input

The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line `0 0', which is not considered as part of the input.

Output

For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc.

Sample Input

1 10
44 497
346 542
1199 1748
1496 1403
1004 503
1714 190
1317 854
1976 494
1001 1960
0 0

Sample Output

1 2 1 1 1 1 1 1 1 1
85 185 185 185 190 96 96 96 95 93
40 40 40 93 136 82 40 40 40 40
115 666 215 215 214 205 205 154 105 106
16 113 19 20 114 20 20 19 19 16
107 105 100 101 101 197 200 200 200 200
413 1133 503 503 503 502 502 417 402 412
196 512 186 104 87 93 97 97 142 196
398 1375 398 398 405 499 499 495 488 471
294 1256 296 296 296 296 287 286 286 247

Source

Shanghai 2004

又是一道数位dp,似乎不是套路。

设:dp[i][j]表示i位数,j出现的次数。


#include<algorithm>
#include<iostream>
#include<cstdio>
using namespace std;
int l,r,dp[13][11],a[11],sma[11],big[11];
void init()
{
	a[0]=1;
	for(int i=1;i<=9;i++)
		a[i]=10*a[i-1];
	for(int i=0;i<=9;i++)
		dp[1][i]=1;
	for(int i=1;i<=9;i++)
		for(int j=0;j<=9;j++)
			dp[i][j]=dp[i-1][j]*10+a[i-1];
}
int query(int x,int k)//在1~x中查找y出现的次数 
{
	int dig[11],len=0,ans=0,ori=x;
	while(x)
	{
		dig[++len]=x%10;
		x/=10;
	}
	if(k==0)
		for(int i=len-1;i>=1;i--)
			ans-=a[i];
	for(int i=len;i>=1;i--)
	{
		ans+=dig[i]*dp[i-1][k];
		if(dig[i]>k)
			ans+=a[i-1];
		if(dig[i]==k)
			ans+=ori%a[i-1];
	}
	return ans;
}
int main()
{
	init();
	while(~scanf("%d%d",&l,&r))
	{
		if(l==0&&r==0)
			break;
		if(l>r)
			swap(l,r);
		for(int i=0;i<=9;i++)
			big[i]=query(r+1,i);
		for(int i=0;i<=9;i++)
			sma[i]=query(l,i);
		for(int i=0;i<=9;i++)
			printf("%d%c",big[i]-sma[i],i==9?'\n':' ');
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值