PAT---A1006. Sign In and Sign Out (25)

题目要求:
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

参考代码:(代码有监测点无法通过,因此仅供参考,如各位看官发现错误,还望及时通告,谢谢)

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct pNode{
    char id[20];
    int hh,mm,ss;
}temp,ans1,ans2;
//比较函数,如第一个参数比第二个参数大则返回true,否则返回false
bool great(pNode node1,pNode node2)
{
    if(node1.hh !=node2.hh)
        return node1.hh > node2.hh;
    if(node1.mm!=node2.mm)
        return node1.mm>node2.mm;
    return node1.ss >node2.ss;
}
int main()
{
    int n;
    scanf("%d",&n);
    ans1.hh = 24,ans1.mm = 60,ans1.ss = 60;
    ans2.hh = 0,ans2.mm=0,ans2.ss=0;
    for(int i=0;i<n;i++)
    {
        scanf("%s %d:%d:%d",temp.id,&temp.hh,&temp.mm,&temp.ss);
        if(great(temp,ans1)==false)
            ans1 = temp;
        scanf("%d:%d:%d",&temp.hh,&temp.mm,&temp.ss);
        if(great(temp,ans1)==true)
            ans2 = temp;
    }
    printf("%s %s",ans1.id,ans2.id);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值