USACO天梯--Broken Necklace

Broken Necklace


You have a necklace of N red, white, or blue beads (3<=N<=350) some of which are red, others blue, and others white, arranged at random. Here are two examples for n=29:

                1 2                               1 2
            r b b r                           b r r b
          r         b                       b         b
         r           r                     b           r
        r             r                   w             r
       b               r                 w               w
      b                 b               r                 r
      b                 b               b                 b
      b                 b               r                 b
       r               r                 b               r
        b             r                   r             r
         b           r                     r           r
           r       r                         r       b
             r b r                             r r w
            Figure A                         Figure B
                        r red bead
                        b blue bead
                        w white bead

The beads considered first and second in the text that follows have been marked in the picture.

The configuration in Figure A may be represented as a string of b's and r's, where b represents a blue bead and r represents a red one, as follows: brbrrrbbbrrrrrbrrbbrbbbbrrrrb .

Suppose you are to break the necklace at some point, lay it out straight, and then collect beads of the same color from one end until you reach a bead of a different color, and do the same for the other end (which might not be of the same color as the beads collected before this).

Determine the point where the necklace should be broken so that the most number of beads can be collected.

Example

For example, for the necklace in Figure A, 8 beads can be collected, with the breaking point either between bead 9 and bead 10 or else between bead 24 and bead 25.

In some necklaces, white beads had been included as shown in Figure B above. When collecting beads, a white bead that is encountered may be treated as either red or blue and then painted with the desired color. The string that represents this configuration can include any of the three symbols r, b and w.

Write a program to determine the largest number of beads that can be collected from a supplied necklace.

PROGRAM NAME: beads

INPUT FORMAT

Line 1:N, the number of beads
Line 2:a string of N characters, each of which is r, b, or w

SAMPLE INPUT (file beads.in)

29
wwwbbrwrbrbrrbrbrwrwwrbwrwrrb

OUTPUT FORMAT

A single line containing the maximum of number of beads that can be collected from the supplied necklace.

SAMPLE OUTPUT (file beads.out)

11

OUTPUT EXPLANATION

Consider two copies of the beads (kind of like being able to runaround the ends). The string of 11 is marked.
                Two necklace copies joined here
                             v
wwwbbrwrbrbrrbrbrwrwwrbwrwrrb|wwwbbrwrbrbrrbrbrwrwwrbwrwrrb
                       ******|*****
                       rrrrrb|bbbbb  <-- assignments
                   5xr .....#|#####  6xb

                        5+6 = 11 total




这是一道模拟题,难度更加接近于NOIP的Day1难度,需要一定的是思考量,要注意几个特殊的字符串:
①rrr
②rrwwwwbb
我的想法跟题目的演示想法一样,先把两个相同字符串进行拼接,再从中间进行从左至右的暴力。
但是对于rrr这样的字符串,计数器会显示6,因此你需要进行判断,若计数器大于字符串长度,则最大计数值变为字符串长度。
对②这种情况,存在多个w连续出现,你需要扫描,直至不再出现w,并记录下不是w的字符。
代码如下:
/*
ID:wang ming
PROG:beads
LANG:C++
*/
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    freopen("beads.in","r",stdin);
    freopen("beads.out","w",stdout);
    int len,num,max=0;
    int i,j,k,l;
    char a[410];
    char c[820];
    char temp,temp1;
    scanf("%d",&len);
    scanf("%s",&a);
    strcpy(c,a);
    strcat(c,a);
    //printf("%s\n",c);
   for(i=len-1;i>=2;i--)
   {
       num=0;
       if(c[i]=='w')
       {
           for(l=i+1;l<2*len;l++)
           if(c[l]!='w')
           break;
           temp=c[l];
       }
       else
       temp=c[i];
       for(j=i+1;j<2*len;j++)
       {
           if(c[j]==temp||c[j]=='w')
           num++;
           if(c[j]!=temp&&c[j]!='w')
           break;
       }
       if(c[i-1]=='w')
       {
           for(l=i-2;l>=0;l--)
           if(c[l]!='w')
           break;
           temp1=c[l];
       }
       else
       temp1=c[i-1];
       for(k=i-2;k>=0;k--)
       {
           if(c[k]==temp1||c[k]=='w')
           num++;
           if(c[k]!=temp1&&c[k]!='w')
           break;
       }
    if(num+2>len)
    max=len;
    if(max<num+2&&num+2<=len)
    max=num+2;
   }
   printf("%d\n",max);
    return 0;
}

对于我的代码,需要思考为什么要加2?
答案:因为c[i]与c[i-1]不管比不比较都要算2颗珠子。
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值