HDOJ--1005

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 138328    Accepted Submission(s): 33522


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 



这题我最开始是TLE的,超时意味着这题显然可以放弃递归了,那么我们只能来找循环节点了,并不是很难找。找到之后便是简单的套用公式。

循环节点看官还是自己去找找看吧~以下是AC代码:

#include<iostream>
using namespace std;
int main()
{
    int A,B;
    unsigned int n;
    cin>>A>>B>>n;
    while(A&&B&&n)
    {
        int *p=new int[50];    
        if(n>50)       /*从50以后便存在循环*/
            n=(n-2)%48+2;
        *p=*(p+1)=1;
        for(int i=2;i<n;i++)
            *(p+i)=(A**(p+i-1)+B**(p+i-2))%7;
        cout<<*(p+n-1)<<endl;
        cin>>A>>B>>n;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值